The Last Sword You Will Ever Need [1.7.2] for Minecraft


The Last Sword You Will Ever Need - this mod for Minecraft adds to your game new swords with huge damage.

Download and get familiar with the mod The Last Sword You Will Ever Need for the game Minecraft using the links below.

Powered by Yandex.Translate

Added: NKT
 2015-06-30 05:13:20
Required client version 1.7.2
Requires Forge API Forge API for Minecraft

 Views: 418
Virus Detection Ratio: 0% (0/58)
 Downloads: 15

Similar mods

Add comment

Not well provided author? Mistakes in mod description? Contact us, buddy!
Add new comment
Top users
0.3